GAliceSms v.1.70

Il piccolo script grafico per l’invio degli sms gratuiti previsti dagli utenti con contratto Telecom-Alice è stato recentemente aggiornato alla versione 1.70. Le recenti modifiche effettuate da Telecom sul portale hanno infatti imposto la completa riscrittura delle procedure di accesso e di controlli.

Sulla pagina web dell’applicazione sono disponibili tutte le istruzioni per l’installazione e l’uso. In particolare, essendo l’applicazione scritta in Perl, sarà necessario aggiungere i seguenti moduli:

LWP::UserAgent
HTML::Form
URI::Escape
Crypt::SSLeay

Gli utenti ubuntu/debian potranno soddisfare tutti i pre-requisiti del programma installando i seguenti pacchetti:

sudo apt-get install libcrypt-ssleay-perl libwww-perl liburi-perl

Il programma può essere scaricato da questo indirizzo.

15 thoughts on “GAliceSms v.1.70

  1. Ciao! Vorrei farti presente dell’esistenza di un programma simile ma molto migliore! Si chiama JackSMS e puoi vederlo qui: http://www.jacksms.it
    Oltre a rossoalice, si possono usare altri servizi, come tim, tin.it, vodafone e molti altri ancora!!! :P

  2. Pingback: GAliceSms, inviare SMS da Telecom/Alice | Giovanni Raco

  3. @dookle07: e allora? C’è sempre qualcosa di meglio al mondo. In ogni caso non ho trovato la licenza di jacksms, che non mi pare sia GPL2 come il mio script. Comunque grazie per l’informazione, se non ti serve galicesms (che comunque metto a disposizione della comunità Open Source e il cui mantenimento in costante aggiornamento mi richiede più di qualche ora di lavoro ), non lo usare! Mia nonna era solita ripetere, in occasioni simili, un vecchio detto popolare: “Fai del bene ai somari, e calci in culo ricevi!”

  4. Dai Fabio non te la prendere, il tipo ha solo fatto un po’ di promozione al suo programma… anche se capisco che infastidisca.

    Io volevo ringraziarti per il tuo script però volevo chiederti delucidazioni sul perché a me continua a dare “Non riesco ad accedere alla pagina di invio SMS!”.
    Ho installato i requisiti e poi eseguito la procedura con la versione 1.73.
    Un saluto e grazie

    • Quell’errore potrebbe essere causato da un temporaneo problema al portale Telecom. Il programma è stato testato e funziona in tutte le configurazioni possibili. Accertati prima che con la tua utenza e password tu riesca a inviare gli sms dal portale.

  5. Grazie per la risposta,
    il problema era che come nome utente avevo inserito anche “@alice.it”, senza funziona.

    Se hai tempo per perfezionare il programma sarebbe bello che diventasse un deb installabile con un clic, così che domandi e installi le dipendenze all’installazione in automatico, poi che i file nascosti nella home fossero contenuti dentro una cartella e che ci fosse un’icona per il programma. Io uso questa, ma credo che non sia possibile integrarla nel tuo script perché è il logo di Alice rimpicciolito e reso trasparente.
    Grazie per la condivisione,
    un saluto

    • Fare un deb per poche centinaia di linee di uno script? Non ne vale certamente la pena. Inoltre, così com’è ora puoi farlo girare su qualunque distribuzione Linux, mentre con un deb solo su Ubuntu/Debian. Credo sia molto più flessibile così, in ogni caso ciò non toglie che chi vuole possa farne un deb, un rpm o qualunque altra cosa. Grazie.

      • Ne vale la pena se vuoi semplificare l’installazione e aumentare la sua diffusione (ubuntu è la più diffusa e il fatto che c’è un deb non vuol dire che allora non deve esserci il solo script valido per le altre distribuzioni…).
        Se non ti interessa, allora non ne vale la pena, ma non è che certamente non ne vale la pena.
        Tra l’altro gli altri che hanno cose simili al tuo (jacksms e moiosms) hanno proprio il loro repository con deb.

      • L’open source è bello per questo. Alcuni scrivono applicazioni, altri le modificano, altri ancora le pacchettizzano, altri le traducono e così via. Tutti insieme.

  6. Ragazzi,
    come faccio ad installare la nuova versione 1.73.
    Scarico il file “compresso” dal sito, lo apro con “winrar” e decompresso risulta un unico file del programma, questo: “galicesms”.
    Quando lo apro mi visualizza la finestra “Apri con”, quindi devo scegliere un software sul pc per installarlo.
    Mi aspettavo la classica schermata di installazione, tipo setup automatico.
    Fatemi sapere se vi risulta come fà a me quindi come risolvere per installarlo.
    Grazie,
    ciao a tutti!.

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...